CodePlex Modbus Slave Simulator Problem

Oct 16, 2013 at 4:52 PM
Hi,

I am trying to use the slave simulator from your site to send some data to my master. However,
seems like only the CodePlex Master Simulator can pick up all the data that is sent from CodePlex Slave Simulator, no other master simulator works... The one I used is CAS Modbus Scanner, which can be downloaded here: http://freemodbus.com/download/

Again, I tried to use another slave simulator send data to CodePlex Master Simulator, the master didn't pick up the data either.. The slave simulator I used is mod_RSsim which can be downloaded here: http://www.plcsimulator.org/downloads

The communication can be done between CAS Modbus Scanner as Master and mod_RSsim as slave. so I am wondering maybe there is something wrong in your master and slave pair? Could you spend some time to fix this? Thank you.
Coordinator
Oct 19, 2013 at 1:49 PM
Thanks for the info, could you let me know what function you're using (read coils, registers...) or does it not work with any?
Oct 21, 2013 at 6:37 PM
none of them works
Coordinator
Nov 12, 2013 at 3:14 AM
I tried the freemodbus master with the codeplex slave (Oct 04 Release, change set 26444)
I used tcp 127.0.0.1 502
Set the slave ID to 1 on both master and slave
Read holding registers at 40001

I was able to read data from the codeplex slave using the freemodbus master

I then tried the plcSimulator slave with the codeplex master using
TCP 127.0.0.1 502
Slave ID set to 1 on both
Requested read register at 0001
I was also able to read data from the plcSimulator using the codeplex modbus master

Both tests were done on a windows XP SP3 running under VMWare.
Windows firewall exceptions were added for each.

I noticed that the default slave ID was 1 for the codeplex slave and 0 for the CAS scanner, make sure they are both set to the same.
Nov 13, 2013 at 5:02 PM
Thank you for your info! Now it works too on my side.

1 question, how do I write single coil into a slave?